Engine whine.

Discussions relating to Turbochargers, Superchargers, Induction, Engine Mods, Exhaust Mods, and other items specifically to make your MX5 or Roadster put out more power.

Moderators: Growler, jif, SLYDIT, Born_disturbed

Post Reply
jakx784
Hey. They are NOT Training wheels.
Hey.  They are NOT Training wheels.
Posts: 5
Joined: Mon May 27, 2019 10:44 pm

Engine whine.

Post by jakx784 » Wed Jul 03, 2019 3:15 pm

Hi there,

Recently did a Cambelt change on my 92' na mx5 (Cambelt, water pump, seals, accessory belts tensioner/idler etc. were all replaced). I then had to fix the common problem with the t-piece coming off the bottom half of the thermostat housing. All done and dusted I thought.

When I had gotten the car up to temperature to bleed the cooling system the car made a whine from what seemed like the cam cover. It responded to revs (higher the revs, the more high pitched it became). I left it overnight and I started the car, noise was still there but much quieter. I took off the cam cover and nothing seems wrong. Cambelt is intact/proper tension.

We tried very briefly running it without the power steering belt on and it still made the noise.

It sounded like belt rub, or something but I just ordered direct replacements for all the accessory belts and as I said I could see nothing wrong with the Cambelt or tensioner/idler.

If anyone could lend some advice on what might be the Issue I would greatly appreciate it.

P.S
I apologize if this is the wrong thread but I'm new here and I honestly just need some help.

Post Reply

Return to “MX5 Power & Power Mods”

Who is online

Users browsing this forum: No registered users and 5 guests